Back to CVE records
Critical 9.3Published Dec 8, 2025

CVE-2025-66568ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation

Updated under an hour ago ()

Does this affect you?

It affects SAML-Toolkits ruby-saml and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

The ruby-saml library implements the client side of an SAML authorization. Versions up to and including 1.12.4, are vulnerable to authentication bypass through the libxml2 canonicalization process used by Nokogiri for document transformation, which allows an attacker to execute a Signature Wrapping attack. When libxml2’s canonicalization is invoked on an invalid XML input, it may return an empty string rather than a canonicalized node. ruby-saml then proceeds to compute the DigestValue over this empty string, treating it as if canonicalization succeeded. This issue is fixed in version 1.18.0.

CVSS
9.3 CRITICAL (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-347
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 9, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
SAML-Toolkits ruby-saml
saml_toolkits:ruby_saml (from the name)
before 1.18.0
CNA record
onelogin ruby-saml
onelogin:ruby-saml
before 1.18.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.