Back to CVE records
Low 1.3Published Dec 5, 2025

CVE-2025-66581Frappe LMS is Missing Server-Side Authorization in Business Logic

Updated under an hour ago ()

Does this affect you?

It affects frappe lms and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Frappe Learning Management System (LMS) is a learning system that helps users structure their content. Prior to 2.41.0, a flaw in the server-side authorization logic allowed authenticated users to perform actions beyond their assigned roles across multiple features. Because the affected endpoints relied on client-side or UI-level checks instead of enforcing permissions on the server, users with low-privileged roles (such as students) could perform operations intended only for instructors or administrators via directly using the API's. This vulnerability is fixed in 2.41.0.

CVSS
1.3 LOW (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:U
Weakness (CWE)
CWE-863
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 5, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
frappe lms
frappe:lms (from the name)
before 2.41.0
CNA record
frappe learning
frappe:learning
before 2.41.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.