Back to CVE records
High 8.2Published Dec 10, 2025

CVE-2025-66675Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS) - version ranges fixed

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Struts and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to  https://cve.org/CVERecord?id=CVE-2025-64775  - this CVE addresses missing affected version 6.7.4

CVSS
8.2 HIGH (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Weakness (CWE)
CWE-459
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Dec 10, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache Struts
apache_software_foundation:apache_struts (from the name)
from 2.0.0 through 6.7.*; from 7.0.0 through 7.0.*
CNA record
apache struts
apache:struts
from 2.0.0 through 2.3.37; from 2.5.0 through 2.5.33; from 6.0.0 before 6.8.0; from 7.0.0 before 7.1.1
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.