Back to CVE records
Medium 5.4Published Dec 10, 2025

CVE-2025-67490Auth0 Next.js SDK has Improper Request Caching Lookup

Updated under an hour ago ()

Does this affect you?

It affects auth0 nextjs-auth0 and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This issue is fixed in versions 4.11.2 and 4.12.1.

CVSS
5.4 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N
Weakness (CWE)
CWE-863
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 11, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
auth0 nextjs-auth0
auth0:nextjs_auth0 (from the name)
from 4.12.0, < 4.12.1; from 4.11.0, < 4.11.2
CNA record
auth0 nextjs-auth0
auth0:nextjs-auth0
4.11.0; 4.11.1; 4.12.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.