Back to CVE records
Critical 9.1Published Dec 8, 2025

CVE-2025-67504WBCE CMS has Weak Random Number Generator in Password Generation Function

Updated under an hour ago ()

Does this affect you?

It affects WBCE_CMS and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege escalation if these passwords are used for new accounts or password resets. The vulnerability is fixed in version 1.6.5.

CVSS
9.1 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness (CWE)
CWE-331, CWE-338
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 9, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
WBCE WBCE_CMS
wbce:cms (from the name)
before 1.6.5
CNA record
wbce wbce_cms
wbce:wbce_cms
before 1.6.5
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.