Back to CVE records
High 7.1Published Dec 10, 2025

CVE-2025-67648Shopware's inproper input validation can lead to Reflected XSS through Storefront Login Page

Updated under an hour ago ()

Does this affect you?

It affects shopware. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Shopware is an open commerce platform. Versions 6.4.6.0 through 6.6.10.9 and 6.7.0.0 through 6.7.5.0 have a Reflected XSS vulnerability in AuthController.php. A request parameter from the login page URL is directly rendered within the Twig template of the Storefront login page without further processing or input validation. This allows direct code injection into the template via the URL parameter, waitTime, which lacks proper input validation. This issue is fixed in versions 6.6.10.10 and 6.7.5.1.

CVSS
7.1 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Dec 11, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
shopware shopware
shopware:shopware (from the name)
from 6.4.6.0, < 6.6.10.10; from 6.7.0.0, < 6.7.5.1
CNA record
shopware shopware
shopware:shopware
from 6.4.6.0 before 6.6.10.10; from 6.7.0.0 before 6.7.5.1
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.