CVE-2025-68698Jervis has an RSA PKCS#1 v1.5 Padding Vulnerability
Updated under an hour ago ()
Does this affect you?
It affects samrocketman jervis. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, Jervis uses PKCS1Encoding which is vulnerable to Bleichenbacher padding oracle attacks. Modern systems should use OAEP (Optimal Asymmetric Encryption Padding). This vulnerability is fixed in 2.2.
- CVSS
- 8.7 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- Weakness (CWE)
- CWE-327
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- Jan 15, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
samrocketman jervis samrocketman:jervis (from the name) | before 2.2 | CNA record |
samrocketman jervis samrocketman:jervis | before 2.2 | NVD |
References
- https://github.com/samrocketman/jervis/security/advisories/GHSA-mqw7-c5gg-xq97x-refsource-confirm, vendor-advisory
- https://github.com/samrocketman/jervis/commit/c3981ff71de7b0f767dfe7b37a2372cb2a51974ax-refsource-misc, patch
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.