Back to CVE records
High 8.8Published Mar 9, 2026

CVE-2025-69219Apache Airflow Providers Http: Unsafe Pickle Deserialization in apache-airflow-providers-http leading to RCE via HttpOperator

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Airflow Providers Http and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low. You should upgrade to version 6.0.0 of the provider to avoid even that risk.

CVSS
8.8 HIGH (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-913
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Mar 9, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache Airflow Providers Http
apache_software_foundation:apache_airflow_providers_http (from the name)
from 5.1.0 before 6.0.0
CNA record
apache airflow_providers_http
apache:airflow_providers_http
from 5.1.0 before 6.0.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.