CVE-2025-69262pnpm vulnerable to Command Injection via environment variable substitution
Updated under an hour ago ()
Does this affect you?
It affects pnpm. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.
- CVSS
- 7.6 HIGH (v3.1, CNA)CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- Weakness (CWE)
- CWE-78, CWE-94
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- Feb 26, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-2phv-j68v-wwqxx-refsource-confirm, exploit, vendor-advisory
- https://github.com/pnpm/pnpm/releases/tag/v10.27.0x-refsource-misc, product, release-notes
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.