Back to CVE records
Medium 5.1Published Jan 28, 2026

CVE-2025-69289Discourse has insecure default configuration that allows non-admin moderators to takeover any non-staff account via email change

Updated under an hour ago ()

Does this affect you?

It affects discourse. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.

CVSS
5.1 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-863
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Jan 28, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
discourse discourse
discourse:discourse (from the name)
before 3.5.4; from 2025.11.0-latest, < 2025.11.2; from 2025.12.0-latest, < 2025.12.1; from 2026.1.0-latest, < 2026.1.0
CNA record
discourse discourse
discourse:discourse
before 3.5.4; from 2025.11.0 before 2025.11.2; 2025.12.0; 2026.1.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.