Back to CVE records
Medium 5.1Published Aug 1, 2026

CVE-2025-71404better-auth before 1.1.16 Reflected XSS via error parameter

Updated under an hour ago ()

Does this affect you?

It affects better-auth. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.

CVSS
5.1 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
VulnCheck
NVD analysis
Deferred
Record last updated
Aug 3, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
better-auth better-auth
better_auth:better_auth (from the name)
before 1.1.16; 1.1.16 not affected
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.