Back to CVE records
Critical 9.3Published Nov 24, 2025

CVE-2025-9803Improper Authentication in lunary-ai/lunary

Updated under an hour ago ()

Does this affect you?

It affects lunary-ai/lunary and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

lunary-ai/lunary version 1.9.34 is vulnerable to an account takeover due to improper authentication in the Google OAuth integration. The application fails to verify the 'aud' (audience) field in the access token issued by Google, which is crucial for ensuring the token is intended for the application. This oversight allows attackers to use tokens issued to malicious applications to gain unauthorized access to user accounts. The issue is resolved in version 1.9.35.

CVSS
9.3 CRITICAL (v3.0, CNA)CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Weakness (CWE)
CWE-287
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
@huntr_ai
NVD analysis
Analyzed
Record last updated
Nov 25, 2025
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
lunary-ai lunary-ai/lunary
lunary_ai:lunary (from the name)
from unspecified before 1.9.35
CNA record
lunary lunary
lunary:lunary
1.9.34
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.