CVE-2026-0259WildFire WF-500 and WF-500-B: Arbitrary File Read and Delete Vulnerability in WildFire Appliance (WF-500, WF-500-B)
Updated under an hour ago ()
Does this affect you?
It affects Palo Alto Networks WildFire WF-500 and WF-500-B and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
An arbitrary File Read and Delete Vulnerability in Palo Alto Networks WildFire® WF-500 and WF-500-B appliances enables users to read sensitive information and delete arbitrary files. This vulnerability affects WF-500 and WF-500-B appliances running in the default non-FIPS configuration mode. The WildFire Appliance (WF-500, WF-500-B) software update is now available to customers that use the WildFire Appliance (WF-500, WF-500-B) for on-premise sandboxing. Please note that customers using the WildFire Public cloud service are NOT impacted by this vulnerability.
- CVSS
- 5.0 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:U/AU:Y/R:U/V:C/RE:M/U:Amber
- Weakness (CWE)
- CWE-73
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- palo_alto
- NVD analysis
- Analyzed
- Record last updated
- May 13, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
Palo Alto Networks WildFire WF-500 and WF-500-B palo_alto_networks:wildfire_wf_500_and_wf_500_b (from the name) | from 12.1.0 before 12.1.7, 12.1.4-h5; fixed at 12.1.7, fixed at 12.1.4-h5; from 11.2.0 before 11.2.11,11.2.7-h7; fixed at 11.2.12, fixed at 11.2.10-h6, fixed at 11.2.7-h13, fixed at 11.2.4-h17; from 11.1.0 before 11.1.13,11.1.10-h8; fixed at 11.1.15, fixed at 11.1.13-h5, fixed at 11.1.10-h25, fixed at 11.1.7-h6, fixed at 11.1.6-h32, fixed at 11.1.4-h33; from 10.2.0 before 10.2.18-h6, 10.2.16-h7, 10.2.13-h21, 10.2.10-h36, 10.2.7-h34; fixed at 10.2.18-h6, fixed at 10.2.16-h7, fixed at 10.2.13-h21, fixed at 10.2.10-h36, fixed at 10.2.7-h34 | CNA record |
paloaltonetworks pan-os paloaltonetworks:pan-os | before 10.2.7; from 10.2.8 before 10.2.10; from 10.2.11 before 10.2.13; from 10.2.14 before 10.2.16; 10.2.7; 10.2.7; 10.2.7; 10.2.7; and 163 more ranges | NVD |
References
- https://security.paloaltonetworks.com/CVE-2026-0259vendor-advisory
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.