Back to CVE records
Low 3.5Published Oct 28, 2026

CVE-2026-105612PostgreSQL Anonymizer: Data-modifying CTEs bypass the read-only restriction of masked roles

Updated under an hour ago ()

Does this affect you?

It affects DALIBO PostgreSQL Anonymizer. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

Free: a daily email for up to 3 products and the weekly digest. No card, no password. By continuing you agree to the Terms and Privacy Policy.

CVSS
3.5 LOW (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Weakness (CWE)
CWE-862
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
PostgreSQL
NVD analysis
Awaiting Analysis
Record last updated
Oct 28, 2026
First seen by InfoSec Signals
Oct 28, 2026

Affected products

Affected products
DALIBO PostgreSQL Anonymizer
dalibo:postgresql_anonymizer (from the name)
from 1 before 3.3.0
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Essential cookies only, unless you allow a Google ads cookie. See our .