Back to CVE records
High 7.5Published Oct 26, 2026

CVE-2026-105626Consul vulnerable to a denial of service in HTTP APIs

Updated under an hour ago ()

Does this affect you?

It affects HashiCorp Consul and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

HashiCorp Consul and Consul Enterprise are vulnerable to a denial of service in the HTTP API that may allow an unauthenticated attacker to exhaust memory on a Consul agent. This vulnerability (CVE-2026-105626) is fixed in Consul Community Edition 2.1.0 and Consul Enterprise 2.1.0 and 1.21.19.

CVSS
7.5 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness (CWE)
CWE-770
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
HashiCorp
NVD analysis
Awaiting Analysis
Record last updated
Oct 26, 2026
First seen by InfoSec Signals
Oct 26, 2026

Affected products

Affected products
HashiCorp Consul
hashicorp:consul (from the name)
from 0.6.0 before 2.1.0
CNA record
HashiCorp Consul Enterprise
hashicorp:consul_enterprise (from the name)
from 0.6.0 before 2.1.0; fixed at 1.21.19
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.