CVE-2026-112712@fastify/middie vulnerable to path-scoped middleware bypass via scope prefix mismatch
Updated under an hour ago ()
Does this affect you?
It affects @fastify/middie. Add what you run to find out whether that includes you.
EPSS puts the chance of exploitation in the next 30 days at 0.31%, higher than 23% of scored CVEs.
Do this next
Free account, 1 product
@fastify/middie is the Express-style middleware engine for Fastify. In versions from 9.0.0 through 9.3.5, the use() function joined a path-scoped middleware's mount path to the plugin scope prefix in a way that could diverge from the path Fastify's router serves, most often when the scope prefix ended in a slash, and also for array mount paths and for mount paths written without a leading slash. When the two paths disagreed, the middleware was silently skipped while the route handler still ran, so path-scoped middleware such as authentication, authorization, or rate limiting could be bypassed by a single unauthenticated request. The issue is fixed in @fastify/middie 9.3.6, and users should upgrade to 9.3.6 or later. As a workaround, enforce authorization in a Fastify hook such as preHandler that runs after the router has resolved the request.
- CVSS
- 9.1 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weakness (CWE)
- CWE-436
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- 0.31% (percentile 23)
- Assigned by
- openjs
- NVD analysis
- Deferred
- Record last updated
- Oct 20, 2026
- First seen by InfoSec Signals
- Oct 20, 2026
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.