Back to CVE records
High 7.1Published Oct 24, 2026

CVE-2026-114178WordPress W3 Total Cache plugin <= 2.10.7 - Cross Site Scripting (XSS) vulnerability

Updated under an hour ago ()

Does this affect you?

It affects Bold Grid W3 Total Cache. Add what you run to find out whether that includes you.

EPSS puts the chance of exploitation in the next 30 days at 0.21%, higher than 10% of scored CVEs.

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bold Grid W3 Total Cache w3-total-cache allows Stored XSS.This issue affects W3 Total Cache: from n/a through 2.10.7.

CVSS
7.1 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
0.21% (percentile 10)
Assigned by
Patchstack
NVD analysis
Deferred
Record last updated
Oct 24, 2026
First seen by InfoSec Signals
Oct 24, 2026

Affected products

Affected products
Bold Grid W3 Total Cache
bold_grid:w3_total_cache (from the name)
through 2.10.7; fixed at 2.11.0
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.