Back to CVE records
Medium 6.5Published Oct 26, 2026

CVE-2026-115914vLLM DeepSeek-OCR image processing vulnerable to denial of service

Updated under an hour ago ()

Does this affect you?

It affects vllm-project vllm and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

vLLM is an inference and serving engine for large language models. From 0.11.1 until 0.32.0, the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path allows a remote client that can reach the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when that image is alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users. This issue is fixed in version 0.32.0.

CVSS
6.5 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness (CWE)
CWE-617
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Oct 26, 2026
First seen by InfoSec Signals
Oct 26, 2026

Affected products

Affected products
vllm-project vllm
vllm_project:vllm (from the name)
from 0.11.1, < 0.32.0
CNA record
vllm vllm
vllm:vllm
from 0.11.1 before 0.32.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.