CVE-2026-115915vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
Updated under an hour ago ()
Does this affect you?
It affects vllm-project vllm and 1 other product. Add what you run to find out whether that includes you.
EPSS puts the chance of exploitation in the next 30 days at 0.66%, higher than 51% of scored CVEs.
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
- CVSS
- 8.1 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weakness (CWE)
- CWE-20, CWE-183
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- 0.66% (percentile 51)
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- Oct 26, 2026
- First seen by InfoSec Signals
- Oct 26, 2026
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.