Back to CVE records
Low 3.1Published Oct 27, 2026

CVE-2026-116687CKEditor: Cross-site scripting (XSS) in the engine package

Updated under an hour ago ()

Does this affect you?

It affects ckeditor5. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.

Free: a daily email for up to 3 products and the weekly digest. No card, no password. By continuing you agree to the Terms and Privacy Policy.

CVSS
3.1 LOW (v3.1, CNA)CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Awaiting Analysis
Record last updated
Oct 27, 2026
First seen by InfoSec Signals
Oct 27, 2026

Affected products

Affected products
ckeditor ckeditor5
ckeditor:ckeditor5 (from the name)
from 29.0.0, < 47.7.4; from 48.0.0, < 48.5.1
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Essential cookies only, unless you allow a Google ads cookie. See our .