Back to CVE records
High 8.1Published Oct 27, 2026

CVE-2026-116688CKEditor: Cross-site scripting (XSS) in the engine package

Updated under an hour ago ()

Does this affect you?

It affects ckeditor5. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 45.0.0 until 47.7.4 and 48.5.1, the engine uses a vulnerable es-toolkit version whose prototype-pollution behavior can be reached while CKEditor processes incoming style attribute values. Crafted editor content can thereby cause unauthorized JavaScript execution in the browser. This issue is fixed in versions 47.7.4 and 48.5.1.

CVSS
8.1 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Awaiting Analysis
Record last updated
Oct 27, 2026
First seen by InfoSec Signals
Oct 27, 2026

Affected products

Affected products
ckeditor ckeditor5
ckeditor:ckeditor5 (from the name)
from 45.0.0, < 47.7.4; from 48.0.0, < 48.5.1
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.