Back to CVE records
High 7.8Published Jun 23, 2026

CVE-2026-12957Arbitrary Code Execution in Language Servers for AWS

Updated under an hour ago ()

Does this affect you?

It affects Amazon Web Services Language Servers for AWS. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

CVSS
7.8 HIGH (v3.1, CNA)CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-732
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
AMZN
NVD analysis
Awaiting Analysis
Record last updated
Jun 23, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Amazon Web Services Language Servers for AWS
amazon_web_services:language_servers_for_aws (from the name)
before 1.65.0
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.