Back to CVE records
High 7.4Published Jul 31, 2026

CVE-2026-18394Incorrect authorization in Strands Agents Tools http_request proxy credential exfiltration

Updated under an hour ago ()

Does this affect you?

It affects AWS Strands Agents Tools. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Incorrect authorization in the http_request tool in Strands Agents Tools before 0.8.2 might allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through actor-controlled proxy infrastructure. To remediate this issue, users should upgrade to version 0.8.2.

CVSS
7.4 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
Weakness (CWE)
CWE-863
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
AMZN
NVD analysis
Awaiting Analysis
Record last updated
Jul 31, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
AWS Strands Agents Tools
aws:strands_agents_tools (from the name)
before 0.8.2
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.