CVE-2026-2005PostgreSQL pgcrypto heap buffer overflow executes arbitrary code
Updated under an hour ago ()
Does this affect you?
It affects Red Hat Enterprise Linux 10 and 9 other products. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.
- CVSS
- 8.8 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weakness (CWE)
- CWE-122, CWE-120
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- PostgreSQL
- NVD analysis
- Modified
- Record last updated
- Jul 14, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
Red Hat Red Hat Enterprise Linux 10 redhat:enterprise_linux | from 0:16.13-1.el10_1 not affected; from 0:16.13-1.el10_2 not affected | CISA ADP |
Red Hat Red Hat Enterprise Linux 10.0 Extended Update Support redhat:enterprise_linux_eus | from 0:16.13-1.el10_0 not affected | CISA ADP |
Red Hat Red Hat Enterprise Linux 8.2 Advanced Update Support redhat:rhel_aus | from 8020020260309120440.4cda2c84 not affected | CISA ADP |
Red Hat Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On redhat:rhel_eus_long_life | from 8040020260305144728.522a0ee4 not affected | CISA ADP |
from 8060020260306113941.ad008a3a not affected | CISA ADP | |
from 8060020260306113941.ad008a3a not affected | CISA ADP | |
Red Hat Red Hat Enterprise Linux 9.4 Extended Update Support redhat:rhel_eus | from 0:13.23-1.el9_4.1 not affected | CISA ADP |
Red Hat Red Hat Hardened Images redhat:hummingbird | from 18.3-1.2.hum1 not affected | CISA ADP |
Red Hat Red Hat Update Infrastructure 5 redhat:rhui | from 1773670137 not affected | CISA ADP |
postgresql postgresql postgresql:postgresql | from 14.0 before 14.21; from 15.0 before 15.16; from 16.0 before 16.12; from 17.0 before 17.8; from 18.0 before 18.2 | NVD |
References
- https://www.postgresql.org/support/security/CVE-2026-2005/vendor-advisory
- https://access.redhat.com/errata/RHSA-2026:19009
- https://access.redhat.com/errata/RHSA-2026:19010
- https://access.redhat.com/errata/RHSA-2026:3730
- https://access.redhat.com/errata/RHSA-2026:3887
- https://access.redhat.com/errata/RHSA-2026:3896
- https://access.redhat.com/errata/RHSA-2026:4024
- https://access.redhat.com/errata/RHSA-2026:4059
- https://access.redhat.com/errata/RHSA-2026:4063
- https://access.redhat.com/errata/RHSA-2026:4064
- https://access.redhat.com/errata/RHSA-2026:4074
- https://access.redhat.com/errata/RHSA-2026:4075
- https://access.redhat.com/errata/RHSA-2026:4110
- https://access.redhat.com/errata/RHSA-2026:4254
- https://access.redhat.com/errata/RHSA-2026:4441
- https://access.redhat.com/errata/RHSA-2026:4475
- https://access.redhat.com/errata/RHSA-2026:4504
- https://access.redhat.com/errata/RHSA-2026:4505
- https://access.redhat.com/errata/RHSA-2026:4506
- https://access.redhat.com/errata/RHSA-2026:4509
- https://access.redhat.com/errata/RHSA-2026:4515
- https://access.redhat.com/errata/RHSA-2026:4516
- https://access.redhat.com/errata/RHSA-2026:4518
- https://access.redhat.com/errata/RHSA-2026:4524
- https://access.redhat.com/errata/RHSA-2026:4528
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.