Back to CVE records
Critical 10.0Published Jan 7, 2026

CVE-2026-21877n8n is vulnerable to Remote Code Execution via Arbitrary File Write

Updated under an hour ago ()

Does this affect you?

It affects n8n-io n8n and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

n8n is an open source workflow automation platform. In versions 0.121.2 and below, an authenticated attacker may be able to execute malicious code using the n8n service. This could result in full compromise and can impact both self-hosted and n8n Cloud instances. This issue is fixed in version 1.121.3. Administrators can reduce exposure by disabling the Git node and limiting access for untrusted users, but upgrading to the latest version is recommended.

CVSS
10.0 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness (CWE)
CWE-94, CWE-434
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Jan 8, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
n8n-io n8n
n8n_io:n8n (from the name)
before 1.121.3
CNA record
n8n n8n
n8n:n8n
from 0.123.0 before 1.121.3
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.