Back to CVE records
High 7.5Published Jan 15, 2026

CVE-2026-22265Roxy-WI has a Command Injection via grep parameter in logs.py allows authenticated RCE

Updated under an hour ago ()

Does this affect you?

It affects roxy-wi and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Prior to 8.2.8.2, command injection vulnerability exists in the log viewing functionality that allows authenticated users to execute arbitrary system commands. The vulnerability is in app/modules/roxywi/logs.py line 87, where the grep parameter is used twice - once sanitized and once raw. This vulnerability is fixed in 8.2.8.2.

CVSS
7.5 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-78
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Jan 15, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
roxy-wi roxy-wi
roxy_wi:roxy_wi (from the name)
before 8.2.8.2
CNA record
roxy-wi roxy-wi
roxy-wi:roxy-wi
before 8.2.8.2
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.