Back to CVE records
Critical 9.8Published Feb 2, 2026

CVE-2026-22778vLLM leaks a heap address when PIL throws an error

Updated under an hour ago ()

Does this affect you?

It affects vllm-project vllm and 4 other products. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/FFmpeg to achieve remote code execution. This vulnerability is fixed in 0.14.1.

CVSS
9.8 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-532, CWE-209
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Modified
Record last updated
Jul 14, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
vllm-project vllm
vllm_project:vllm (from the name)
from 0.8.3, < 0.14.1
CNA record
Red Hat Red Hat AI Inference Server 3.2
redhat:ai_inference_server
from 1772160593 not affected
CISA ADP
from 1772093436 not affected
CISA ADP
3
CISA ADP
vllm vllm
vllm:vllm
from 0.8.3 before 0.14.1
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.