Back to CVE records
Critical 9.4Published Jan 12, 2026

CVE-2026-22813Malicious website can execute commands on the local system through XSS in the OpenCode web UI

Updated under an hour ago ()

Does this affect you?

It affects anomalyco opencode and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

OpenCode is an open source AI coding agent. The markdown renderer used for LLM responses will insert arbitrary HTML into the DOM. There is no sanitization with DOMPurify or even a CSP on the web interface to prevent JavaScript execution via HTML injection. This means controlling the LLM response for a chat session gets JavaScript execution on the http://localhost:4096 origin. This vulnerability is fixed in 1.1.10.

CVSS
9.4 CRITICAL (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Jan 13, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
anomalyco opencode
anomalyco:opencode (from the name)
before 1.1.10
CNA record
anoma opencode
anoma:opencode
before 1.1.10
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.