Back to CVE records
High 7.5Published Jan 16, 2026

CVE-2026-23490pyasn1 has a DoS vulnerability in decoder

Updated under an hour ago ()

Does this affect you?

It affects pyasn1 and 28 other products. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.2, a Denial-of-Service issue has been found that leads to memory exhaustion from malformed RELATIVE-OID with excessive continuation octets. This vulnerability is fixed in 0.6.2.

CVSS
7.5 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness (CWE)
CWE-770
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Modified
Record last updated
Sep 17, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
pyasn1 pyasn1
pyasn1:pyasn1 (from the name)
before 0.6.2
CNA record
from 0:0.6.3-1.el8ap not affected
CISA ADP
from 0:4.16.0-13.el10_1.2 not affected
CISA ADP
from 0:4.16.0-5.el10_0.8 not affected
CISA ADP
from 0:4.1.1-61.el7_9.23 not affected
CISA ADP
from 0:0.1.9-7.el7_9.2 not affected
CISA ADP
from 0:0.3.7-6.el8_2.1 not affected
CISA ADP
from 0:4.2.1-65.el8_4.27 not affected
CISA ADP
from 0:4.2.1-89.el8_6.21 not affected
CISA ADP
from 0:4.2.1-89.el8_6.21 not affected
CISA ADP

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.