Back to CVE records
High 8.7Published Feb 27, 2026

CVE-2026-2359Multer vulnerable to Denial of Service via resource exhaustion

Updated under an hour ago ()

Does this affect you?

It affects expressjs multer and 5 other products. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by dropping connection during file upload, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

CVSS
8.7 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-772
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
openjs
NVD analysis
Modified
Record last updated
Jul 14, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
expressjs multer
expressjs:multer (from the name)
from 0.0.0 before 2.1.0
CNA record
from 1774545605 not affected
CISA ADP
5
CISA ADP
10
CISA ADP
Red Hat Red Hat Trusted Profile Analyzer
redhat:trusted_profile_analyzer
2
CISA ADP
2
CISA ADP
expressjs multer
expressjs:multer
before 2.1.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.