Back to CVE records
Critical 9.3Published Apr 13, 2026

CVE-2026-23891Decidim has a Cross-site scripting (XSS) vulnerability via user name field

Updated under an hour ago ()

Does this affect you?

It affects decidim. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.

CVSS
9.3 CRITICAL (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 14, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
decidim decidim
decidim:decidim (from the name)
from 0.31.0.rc1, < 0.31.1; before 0.30.5
CNA record
decidim decidim
decidim:decidim
before 0.30.5; from 0.31.0 before 0.31.1
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.
CVE-2026-23891: Decidim has a Cross-site scripting (XSS) vulnerability via user name field | InfoSec Signals