Back to CVE records
High 8.1Published Apr 24, 2026

CVE-2026-23902Apache DolphinScheduler: Users are able to use tenants that are not defined on the platform during workflow execution.

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache DolphinScheduler and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Incorrect Authorization vulnerability in Apache DolphinScheduler allows authenticated users with system login permissions to use tenants that are not defined on the platform during workflow execution. This issue affects Apache DolphinScheduler versions prior to 3.4.1.  Users are recommended to upgrade to version 3.4.1, which fixes this issue.

CVSS
8.1 HIGH (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weakness (CWE)
CWE-863
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Apr 24, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache DolphinScheduler
apache_software_foundation:apache_dolphinscheduler (from the name)
before 3.4.1
CNA record
apache dolphinscheduler
apache:dolphinscheduler
before 3.4.1
NVD

References

  • vendor-advisory, mailing-list
  • mailing-list, third-party-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.