CVE-2026-23980Apache Superset: Improper Neutralization of Special Elements used in a SQL Command
Updated under an hour ago ()
Does this affect you?
It affects Apache Software Foundation Apache Superset and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.
- CVSS
- 5.3 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- Weakness (CWE)
- CWE-89
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- apache
- NVD analysis
- Analyzed
- Record last updated
- Feb 24, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
Apache Software Foundation Apache Superset apache_software_foundation:apache_superset (from the name) | from 0.0.0 before 6.0.0 | CNA record |
apache superset apache:superset | before 6.0.0 | NVD |
References
- https://lists.apache.org/thread/h4l02zw1pr2vywv0dc5zjn3grdcdhwf4vendor-advisory, mailing-list
- http://www.openwall.com/lists/oss-security/2026/02/24/5mailing-list, third-party-advisory
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.