Back to CVE records
Critical 9.1Published Mar 5, 2026

CVE-2026-24457An unsafe parsing of OpenMQ's configuration in OpenMQ versions <6.5.2 and <6.9.0, allows a remote attacker to read arbitrary files from a MQ Broker's server.

Updated under an hour ago ()

Does this affect you?

It affects Eclipse Foundation Eclipse OpenMQ and 2 other products. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

An unsafe parsing of OpenMQ's configuration in OpenMQ versions <6.5.2 and <6.9.0, allows a remote attacker to read arbitrary files from a MQ Broker's server. A full exploitation could read unauthorized files of the OpenMQ’s host OS. In some scenarios RCE could be achieved. This is fixed in OpenMQ 6.5.2, 6.9.0, and in GlassFish 7.0.26, 7.1.1, and 8.0.2.

CVSS
9.1 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Weakness (CWE)
CWE-22, CWE-27
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
eclipse
NVD analysis
Modified
Record last updated
Aug 5, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Eclipse Foundation Eclipse OpenMQ
eclipse_foundation:eclipse_openmq (from the name)
before 6.5.2; from 6.6.0 before 6.9.0
CNA record
Eclipse Foundation Eclipse GlassFish
eclipse_foundation:eclipse_glassfish (from the name)
before 7.0.26; from 7.1.0 before 7.1.1; from 8.0.0 before 8.0.2
CNA record
eclipse openmq
eclipse:openmq
through 6.5.1
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.