Back to CVE records
Critical 9.2Published Feb 3, 2026

CVE-2026-25237PEAR is Vulnerable to PHP Code Execution via preg_replace /e in Bug Update Emails

Updated under an hour ago ()

Does this affect you?

It affects pearweb. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

PEAR is a framework and distribution system for reusable PHP components. Prior to version 1.33.0, use of preg_replace() with the /e modifier in bug update email handling can enable PHP code execution if attacker-controlled content reaches the evaluated replacement. This issue has been patched in version 1.33.0.

CVSS
9.2 CRITICAL (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-624
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Feb 4, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
pear pearweb
pear:pearweb (from the name)
before 1.33.0
CNA record
pear pearweb
pear:pearweb
before 1.33.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.