CVE-2026-25958Cube privilege escalation via a specially crafted request
Updated under an hour ago ()
Does this affect you?
It affects cube-js cube and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
- CVSS
- 7.7 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- Weakness (CWE)
- CWE-807
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- Feb 11, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
cube-js cube cube_js:cube (from the name) | from 0.27.19, < 1.0.14; from 1.1.0, < 1.4.2; from 1.5.0, < 1.5.13 | CNA record |
cube cube.js cube:cube.js | from 0.27.19 before 1.0.14; from 1.1.0 before 1.4.2; from 1.5.0 before 1.5.13 | NVD |
References
- https://github.com/cube-js/cube/security/advisories/GHSA-v226-32c7-x2v7x-refsource-confirm, vendor-advisory
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.