Back to CVE records
High 7.6Published Feb 19, 2026

CVE-2026-26974Sylde has Improper Control of Generation of Code

Updated under an hour ago ()

Does this affect you?

It affects Tygo-van-den-Hurk Slyde and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.

CVSS
7.6 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-829
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Feb 20, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Tygo-van-den-Hurk Slyde
tygo_van_den_hurk:slyde (from the name)
before 0.0.5
CNA record
slyde.js slyde
slyde.js:slyde
before 0.0.5
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.