Back to CVE records
Critical 9.2Published Mar 3, 2026

CVE-2026-27971Qwik affected by unauthenticated RCE via server$ Deserialization

Updated under an hour ago ()

Does this affect you?

It affects QwikDev qwik and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

CVSS
9.2 CRITICAL (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-502
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Mar 4, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
QwikDev qwik
qwikdev:qwik (from the name)
before 1.19.1
CNA record
qwik qwik
qwik:qwik
before 1.19.1
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.