Back to CVE records
High 8.7Published Mar 6, 2026

CVE-2026-29068PJSIP: Stack buffer overflow in Opus codec parser

Updated under an hour ago ()

Does this affect you?

It affects pjsip pjproject and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, there is a stack buffer overflow vulnerability when pjmedia-codec parses an RTP payload contain more frames than the caller-provided frames can hold. This issue has been patched in version 2.17.

CVSS
8.7 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-121
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Mar 9, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
pjsip pjproject
pjsip:pjproject (from the name)
before 2.17
CNA record
pjsip pjsip
pjsip:pjsip
before 2.17
NVD

References

  • x-refsource-confirm, patch, vendor-advisory
  • x-refsource-misc, patch

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.