Back to CVE records
High 7.7Published Mar 9, 2026

CVE-2026-30929ImageMagick has a stack buffer overflow in MagnifyImage

Updated under an hour ago ()

Does this affect you?

It affects ImageMagick. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, MagnifyImage uses a fixed-size stack buffer. When using a specific image it is possible to overflow this buffer and corrupt the stack. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.

CVSS
7.7 HIGH (v3.1, CNA)CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Weakness (CWE)
CWE-121, CWE-787
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Mar 10, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
ImageMagick ImageMagick
imagemagick:imagemagick (from the name)
from 7.0.0, < 7.1.2-16; before 6.9.13-41
CNA record
imagemagick imagemagick
imagemagick:imagemagick
before 6.9.13-41; from 7.0.0-0 before 7.1.2-16
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.