Back to CVE records
High 8.7Published Mar 10, 2026

CVE-2026-30946Parse Server affected by denial-of-service via unbounded query complexity in REST and GraphQL API

Updated under an hour ago ()

Does this affect you?

It affects parse-community parse-server and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior 9.5.2-alpha.2 and 8.6.15, an unauthenticated attacker can exhaust Parse Server resources (CPU, memory, database connections) through crafted queries that exploit the lack of complexity limits in the REST and GraphQL APIs. All Parse Server deployments using the REST or GraphQL API are affected. This vulnerability is fixed in 9.5.2-alpha.2 and 8.6.15.

CVSS
8.7 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-770
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Mar 11, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
parse-community parse-server
parse_community:parse_server (from the name)
before 8.6.15; from 9.0.0 < 9.5.2-alpha.2
CNA record
parseplatform parse-server
parseplatform:parse-server
before 8.6.15; from 9.0.0 before 9.5.2; 9.5.2
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.