Back to CVE records
High 7.1Published Mar 10, 2026

CVE-2026-30962Parse Server has a protected fields bypass via logical query operators

Updated under an hour ago ()

Does this affect you?

It affects parse-community parse-server and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.

CVSS
7.1 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-284
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Mar 11, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
parse-community parse-server
parse_community:parse_server (from the name)
from 9.0.0 < 9.5.2-alpha.6; before 8.6.19
CNA record
parseplatform parse-server
parseplatform:parse-server
before 8.6.19; from 9.0.0 before 9.5.2; 9.5.2; 9.5.2; 9.5.2; 9.5.2; 9.5.2
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.