Back to CVE records
High 7.2Published Mar 10, 2026

CVE-2026-31834Umbraco Affected by Vertical Privilege Escalation via Missing Authorization Checks

Updated under an hour ago ()

Does this affect you?

It affects Umbraco-CMS and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Umbraco is an ASP.NET CMS. From 15.3.1 to before 16.5.1 and 17.2.2, A privilege escalation vulnerability has been identified in Umbraco CMS. Under certain conditions, authenticated backoffice users with permission to manage users, may be able to elevate their privileges due to insufficient authorization enforcement when modifying user group memberships. The affected functionality does not properly validate whether a user has sufficient privileges to assign highly privileged roles. This vulnerability is fixed in 16.5.1 and 17.2.2.

CVSS
7.2 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-269, CWE-284, CWE-862
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Mar 11, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
umbraco Umbraco-CMS
umbraco:cms (from the name)
from 15.3.1, < 16.5.1; from 17.0.0, < 17.2.1
CNA record
umbraco umbraco_cms
umbraco:umbraco_cms
from 15.3.1 before 16.5.1; from 17.0.0 before 17.2.2
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.