Back to CVE records
Critical 9.3Published Mar 11, 2026

CVE-2026-31840Parse Server has a SQL injection via dot-notation field name in PostgreSQL

Updated under an hour ago ()

Does this affect you?

It affects parse-community parse-server and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.2 and 8.6.28, an attacker can use a dot-notation field name in combination with the sort query parameter to inject SQL into the PostgreSQL database through an improper escaping of sub-field values in dot-notation queries. The vulnerability may also affect queries that use dot-notation field names with the distinct and where query parameters. This vulnerability only affects deployments using a PostgreSQL database. This vulnerability is fixed in 9.6.0-alpha.2 and 8.6.28.

CVSS
9.3 CRITICAL (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-89
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Mar 11, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
parse-community parse-server
parse_community:parse_server (from the name)
from 9.0.0 < 9.6.0-alpha.2; before 8.6.28
CNA record
parseplatform parse-server
parseplatform:parse-server
before 8.6.28; from 9.0.0 before 9.6.0; 9.6.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.