Back to CVE records
Medium 6.3Published Feb 25, 2026

CVE-2026-3209fosrl Pangolin Role verifyApiKeyRoleAccess access control

Updated under an hour ago ()

Does this affect you?

It affects fosrl Pangolin. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

A vulnerability has been found in fosrl Pangolin up to 1.15.4-s.3. This affects the function verifyRoleAccess/verifyApiKeyRoleAccess of the component Role Handler. The manipulation leads to improper access controls. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. Upgrading to version 1.15.4-s.4 mitigates this issue. The identifier of the patch is 5e37c4e85fae68e756be5019a28ca903b161fdd5. Upgrading the affected component is advised.

CVSS
6.3 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C
Weakness (CWE)
CWE-284, CWE-266
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
VulDB
NVD analysis
Deferred
Record last updated
Mar 8, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
fosrl Pangolin
fosrl:pangolin (from the name)
1.15.4-s.0; 1.15.4-s.1; 1.15.4-s.2; 1.15.4-s.3; 1.15.4-s.4 not affected
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.