CVE-2026-32267Craft CMS Vulnerable to Privilege Escalation/Bypass through UsersController->actionImpersonateWithToken()
Updated under an hour ago ()
Does this affect you?
It affects craftcms cms and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.6 and from version 5.0.0-RC1 to before version 5.9.12, a low-privilege user (or an unauthenticated user who has been sent a shared URL) can escalate their privileges to admin by abusing UsersController->actionImpersonateWithToken. This issue has been patched in versions 4.17.6 and 5.9.12.
- CVSS
- 7.7 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Weakness (CWE)
- CWE-863
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- Mar 18, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
craftcms cms craftcms:cms (from the name) | from 4.0.0-RC1, < 4.17.6; from 5.0.0-RC1, < 5.9.12 | CNA record |
craftcms craft_cms craftcms:craft_cms | from 4.0.0.1 before 4.17.6; from 5.0.1 before 5.9.12; 4.0.0; 4.0.0; 4.0.0; 4.0.0; 5.0.0; 5.0.0 | NVD |
References
- https://github.com/craftcms/cms/security/advisories/GHSA-cc7p-2j3x-x7xfx-refsource-confirm, exploit, patch, vendor-advisory
- https://github.com/craftcms/cms/commit/6301e217c5f15617d939c432cb770db50af14b33x-refsource-misc, patch
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.