Back to CVE records
High 7.1Published Mar 13, 2026

CVE-2026-32706PX4 autopilot has a global buffer overflow in crsf_rc via oversized variable-length known packet

Updated under an hour ago ()

Does this affect you?

It affects PX4-Autopilot and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, The crsf_rc parser accepts an oversized variable-length known packet and copies it into a fixed 64-byte global buffer without a bounds check. In deployments where crsf_rc is enabled on a CRSF serial port, an adjacent/raw-serial attacker can trigger memory corruption and crash PX4. This vulnerability is fixed in 1.17.0-rc2.

CVSS
7.1 HIGH (v3.1, CNA)CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
Weakness (CWE)
CWE-120, CWE-787
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Modified
Record last updated
Mar 17, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
PX4 PX4-Autopilot
px4:autopilot (from the name)
before 1.17.0-rc2
CNA record
dronecode px4_drone_autopilot
dronecode:px4_drone_autopilot
before 1.17.0; 1.17.0; 1.17.0; 1.17.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.