Back to CVE records
Critical 9.4Published Mar 30, 2026

CVE-2026-33026nginx-ui Backup Restore Allows Tampering with Encrypted Backups

Updated under an hour ago ()

Does this affect you?

It affects 0xJacky nginx-ui and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui backup restore mechanism allows attackers to tamper with encrypted backup archives and inject malicious configuration during restoration. This issue has been patched in version 2.3.4.

CVSS
9.4 CRITICAL (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Weakness (CWE)
CWE-312, CWE-347, CWE-354
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Mar 31, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
0xJacky nginx-ui
0xjacky:nginx_ui (from the name)
before 2.3.4
CNA record
nginxui nginx_ui
nginxui:nginx_ui
before 2.3.4
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.