CVE-2026-33028Nginx UI: Race Condition Leads to Persistent Data Corruption and Service Collapse
Updated under an hour ago ()
Does this affect you?
It affects 0xJacky nginx-ui and 2 other products. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui application is vulnerable to a Race Condition. Due to the complete absence of synchronization mechanisms (Mutex) and non-atomic file writes, concurrent requests lead to the severe corruption of the primary configuration file (app.ini). This vulnerability results in a persistent Denial of Service (DoS) and introduces a non-deterministic path for Remote Code Execution (RCE) through configuration cross-contamination. This issue has been patched in version 2.3.4.
- CVSS
- 7.1 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N
- Weakness (CWE)
- CWE-362
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- Mar 30, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
0xJacky nginx-ui 0xjacky:nginx_ui (from the name) | before 2.3.4 | CNA record |
nginxui nginx_ui nginxui:nginx_ui | before 2.3.4 | NVD |
uozi cosy uozi:cosy | before 1.30.1 | NVD |
References
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-m468-xcm6-fxg4x-refsource-confirm, exploit, mitigation, vendor-advisory
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.4x-refsource-misc, product, release-notes
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.