Back to CVE records
High 8.2Published Mar 24, 2026

CVE-2026-33331oRPC: Stored XSS in OpenAPI Reference Plugin via unescaped JSON.stringify

Updated under an hour ago ()

Does this affect you?

It affects middleapi orpc and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

oRPC is an tool that helps build APIs that are end-to-end type-safe and adhere to OpenAPI standards. Prior to version 1.13.9, a stored cross-site scripting (XSS) vulnerability exists in the OpenAPI documentation generation of orpc. If an attacker can control any field within the OpenAPI specification (such as info.description), they can break out of the JSON context and execute arbitrary JavaScript when a user views the generated API documentation. This issue has been patched in version 1.13.9.

CVSS
8.2 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Mar 25, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
middleapi orpc
middleapi:orpc (from the name)
before 1.13.9
CNA record
orpc orpc
orpc:orpc
before 1.13.9
NVD

References

  • x-refsource-confirm, exploit, mitigation, vendor-advisory
  • x-refsource-misc, patch
  • x-refsource-misc, product, release-notes

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.